cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco announces new innovations in SD-WAN, ISRs, SD-WAN Services, and Catalyst 9000 Series switches


121
Views
0
Helpful
8
Replies
Highlighted
Beginner

GigabitEthernet changed state randomly

I am having some issues with port configuration port (cisco 2960x) of  Gigaset DECT Manager integrated in Cisco Call Manager.
The state of the configured port randomly changes and the communication between DECT headsets stops. After restart all goes ok. This is the log file:


Nov 9 09:25:32.290: [IDB Gi1/0/17 UDRUYY] LSTATE_REQ: Entry
Nov 9 09:25:32.290: [IDB Gi1/0/17 UDRUYY] LSTATE_REQ: timers not running
Nov 9 09:25:32.290: [IDB Gi1/0/17 UDRUYY] LSTATE_REQ: starting lineproto timer
Nov 9 09:25:32.290: [IDB Gi1/0/17 UDRUYY] LSTATE_REQ: delay 1000
Nov 9 09:25:32.290: [IDB Gi1/0/17 UDRUYY] LSTATE_REQ: Exit
Nov 9 09:25:33.294: [IDB Gi1/0/17 DURUYY] LSTATE_TMR: Entry
Nov 9 09:25:33.294: [IDB Gi1/0/17 DURUYY] LSTATE_TMR: not spoofing, current state: n
Nov 9 09:25:33.294: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/17, changed state to down
Nov 9 09:25:33.294: [IDB Gi1/0/17 DURUYY] LSTATE_TMR: Exit
Nov 9 09:25:34.293: [IDB Gi1/0/17 DURUYY] CSTATE_TMR: Entry
Nov 9 09:25:34.293: [IDB Gi1/0/17 DURUYY] CSTATE_TMR: netidb=Gi1/0/17, linestate: n
Nov 9 09:25:34.293: [IDB Gi1/0/17 DURUYY] LSTATE_REQ: Entry
Nov 9 09:25:34.293: [IDB Gi1/0/17 DURUYY] LSTATE_REQ: timers not running
Nov 9 09:25:34.293: [IDB Gi1/0/17 DURUYY] LSTATE_REQ: Exit
Nov 9 09:25:34.293: [IDB Gi1/0/17 DURUYY] CSTATE_TMR: transition detected
Nov 9 09:25:34.293: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/17, changed state to down
Nov 9 09:25:34.293: [IDB Gi1/0/17 DURUnY] TRANS_ADJ: Entry
Nov 9 09:25:34.293: [IDB Gi1/0/17 DURUnn] TRANS_ADJ: propagating change to subifs
Nov 9 09:25:34.293: [IDB Gi1/0/17 DURUnn] TRANS_ADJ: Exit
Nov 9 09:25:34.293: [IDB Gi1/0/17 DURUnn] CSTATE_TMR: Exit
Nov 9 09:25:46.813: [IDB Gi1/0/17 UDRUnn] LSTATE_REQ: Entry
Nov 9 09:25:46.813: [IDB Gi1/0/17 UDRUnn] LSTATE_REQ: Exit
Nov 9 09:25:48.806: [IDB Gi1/0/17 UDRUnn] CSTATE_TMR: Entry
Nov 9 09:25:48.806: [IDB Gi1/0/17 UDRUnn] CSTATE_TMR: netidb=Gi1/0/17, linestate: Y
Nov 9 09:25:48.806: [IDB Gi1/0/17 UDRUnn] LSTATE_REQ: Entry
Nov 9 09:25:48.806: [IDB Gi1/0/17 UDRUnn] LSTATE_REQ: timers not running
Nov 9 09:25:48.806: [IDB Gi1/0/17 UDRUnn] LSTATE_REQ: starting lineproto timer
Nov 9 09:25:48.806: [IDB Gi1/0/17 UDRUnn] LSTATE_REQ: delay 1000
Nov 9 09:25:48.806: [IDB Gi1/0/17 UDRUnn] LSTATE_REQ: Exit
Nov 9 09:25:48.806: [IDB Gi1/0/17 UDRUnn] CSTATE_TMR: transition detected
Nov 9 09:25:48.806: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/17, changed state to up
Nov 9 09:25:48.806: [IDB Gi1/0/17 UDRUYn] TRANS_ADJ: Entry
Nov 9 09:25:48.809: [IDB Gi1/0/17 UDRUYY] TRANS_ADJ: propagating change to subifs
Nov 9 09:25:48.809: [IDB Gi1/0/17 UDRUYY] TRANS_ADJ: Exit
Nov 9 09:25:48.809: [IDB Gi1/0/17 UDRUYY] CSTATE_TMR: Exit
Nov 9 09:25:49.809: [IDB Gi1/0/17 UDRUYY] LSTATE_TMR: Entry
Nov 9 09:25:49.809: [IDB Gi1/0/17 UDRUYY] LSTATE_TMR: not spoofing, current state: Y
Nov 9 09:25:49.809: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/17, changed state to up
Nov 9 09:25:49.809: [IDB Gi1/0/17 UDRUYY] LSTATE_TMR: informing line state transitions
Nov 9 09:25:49.809: [IDB Gi1/0/17 UDRUYY] TRANS_ADJ: Entry
Nov 9 09:25:49.809: [IDB Gi1/0/17 UDRUYY] TRANS_ADJ: Exit
Nov 9 09:25:49.809: [IDB Gi1/0/17 UDRUYY] ROUTE_ADJ: Entry
Nov 9 09:25:49.809: [IDB Gi1/0/17 UDRUYY] ROUTE_ADJ: Exit
Nov 9 09:25:49.809: [IDB Gi1/0/17 UDRUYY] LSTATE_TMR: Exit
Nov 9 09:26:16.823: %SPANTREE-5-TOPOTRAP: Topology Change Trap for vlan 80

 

And this is the configuration of the port of all - Gigaset Manager and Gigaset Cells:

!
interface GigabitEthernet1/0/17
description ### DECT Manager Gigaset N720 DM Pro ###
switchport access vlan 80
switchport mode access
no mdix auto
!

 

Any help would be very welcome!

Thank you in advance!

8 REPLIES
Rising star

Re: GigabitEthernet changed state randomly

Hi, Can you try to force speed and duplex on both devices?

Regards.

Beginner

Re: GigabitEthernet changed state randomly

You mean

duplex full

speed 100 (the interface of the dect specification is 10/100 Mbps)

 

pp. We have 10 Dect Cells and 1 Dect manager attached to different 2960x switches all with the same conf.

Rising star

Re: GigabitEthernet changed state randomly

Yes, exactly.

Try to fix speed and duplex and check if the flapping stop.

 

Regards.

Beginner

Re: GigabitEthernet changed state randomly

Thank you for the immediate response! I changed the configuration and will keep you informed!
BR

VIP Advisor

Re: GigabitEthernet changed state randomly

Hello

Has mdix been turned off or was that the default?

 

Int gig x/x
mdix auto
spanning-tree portfast



kind regards
Paul

Please don't forget to rate any posts that have been helpful.
Beginner

Re: GigabitEthernet changed state randomly

Hello,
The conf. used to be. :
!
interface GigabitEthernet1/0/17
description ### DECT Manager Gigaset N720 DM Pro ###
switchport access vlan 80
switchport mode access
no mdix auto
!

 

 

Not it is:
!
interface GigabitEthernet1/0/17
description ### DECT Manager Gigaset N720 DM Pro ###
switchport access vlan 80
switchport mode access

duplex full
speed 100

no mdix auto
!

 

BR,
Georgi Petrov

VIP Advisor

Re: GigabitEthernet changed state randomly

Hello

Suggest

interface GigabitEthernet1/0/17
description ### DECT Manager Gigaset N720 DM Pro ###
switchport access vlan 80
switchport mode access
spanning-tree portfast

duplex auto
speed auto

mdix auto



kind regards
Paul

Please don't forget to rate any posts that have been helpful.
Beginner

Re: GigabitEthernet changed state randomly

Hello,
I will try this one for sure. Thank you!
But let first check if speed 100 and duplex full will resolve the issue.
I will keep you informed>
BR,

Georgi Petrov

 

CreatePlease to create content
Ask the Expert- Endpoint Security